summaryrefslogtreecommitdiff
path: root/dev-perl/Curses-UI/Curses-UI-0.960.900-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Curses-UI/Curses-UI-0.960.900-r3.ebuild')
-rw-r--r--dev-perl/Curses-UI/Curses-UI-0.960.900-r3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Curses-UI/Curses-UI-0.960.900-r3.ebuild b/dev-perl/Curses-UI/Curses-UI-0.960.900-r3.ebuild
new file mode 100644
index 000000000000..04c46804b2c4
--- /dev/null
+++ b/dev-perl/Curses-UI/Curses-UI-0.960.900-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MDXI
+DIST_VERSION=0.9609
+inherit perl-module
+
+DESCRIPTION="Perl UI framework based on the curses library"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Curses
+ dev-perl/TermReadKey
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? ( virtual/perl-Test-Simple )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9609-no-dot-inc.patch"
+)
+PERL_RM_FILES=(
+ t/05pod.t
+)