summaryrefslogtreecommitdiff
path: root/dev-perl/CryptX/CryptX-0.68.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/CryptX/CryptX-0.68.0.ebuild')
-rw-r--r--dev-perl/CryptX/CryptX-0.68.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/CryptX/CryptX-0.68.0.ebuild b/dev-perl/CryptX/CryptX-0.68.0.ebuild
new file mode 100644
index 000000000000..fe1367c211f5
--- /dev/null
+++ b/dev-perl/CryptX/CryptX-0.68.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DIST_AUTHOR=MIK
+DIST_VERSION=0.068
+inherit perl-module
+
+DESCRIPTION="Self-contained crypto toolkit"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? (
+ || (
+ dev-perl/Cpanel-JSON-XS
+ dev-perl/JSON-XS
+ virtual/perl-JSON-PP
+ )
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ !minimal? (
+ >=virtual/perl-Math-BigInt-1.999.715
+ >=virtual/perl-Storable-2.0.0
+ )
+ )
+"
+PERL_RM_FILES=(
+ t/002_all_pm.t
+ t/003_all_pm_pod.t
+ t/004_all_pm_pod_spelling.t
+ t/005_all_pm_pod_coverage.t
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}