summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r2.ebuild')
-rw-r--r--dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r2.ebuild b/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r2.ebuild
new file mode 100644
index 000000000000..d144fc5de02c
--- /dev/null
+++ b/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=AMS
+DIST_VERSION=2.17
+inherit perl-module
+
+DESCRIPTION="The Twofish Encryption Algorithm"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+PATCHES=("${FILESDIR}/no-dot-inc.patch")
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}