summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-Rijndael/Crypt-Rijndael-1.140.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Crypt-Rijndael/Crypt-Rijndael-1.140.0-r1.ebuild')
-rw-r--r--dev-perl/Crypt-Rijndael/Crypt-Rijndael-1.140.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Rijndael/Crypt-Rijndael-1.140.0-r1.ebuild b/dev-perl/Crypt-Rijndael/Crypt-Rijndael-1.140.0-r1.ebuild
new file mode 100644
index 000000000000..26733862f2ff
--- /dev/null
+++ b/dev-perl/Crypt-Rijndael/Crypt-Rijndael-1.140.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=LEONT
+DIST_VERSION=1.14
+inherit perl-module
+
+DESCRIPTION="Crypt::CBC compliant Rijndael encryption module"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}