summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.60.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.60.0-r1.ebuild')
-rw-r--r--dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.60.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.60.0-r1.ebuild b/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.60.0-r1.ebuild
new file mode 100644
index 000000000000..4efb9c207604
--- /dev/null
+++ b/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.60.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TODDR
+DIST_VERSION=0.06
+inherit perl-module
+
+DESCRIPTION="Perl extension for the RIPEMD-160 Hash function"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}