summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-DES/Crypt-DES-2.70.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Crypt-DES/Crypt-DES-2.70.0-r2.ebuild')
-rw-r--r--dev-perl/Crypt-DES/Crypt-DES-2.70.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Crypt-DES/Crypt-DES-2.70.0-r2.ebuild b/dev-perl/Crypt-DES/Crypt-DES-2.70.0-r2.ebuild
new file mode 100644
index 000000000000..ebaea9455c7b
--- /dev/null
+++ b/dev-perl/Crypt-DES/Crypt-DES-2.70.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DPARIS
+DIST_VERSION=2.07
+inherit perl-module
+
+DESCRIPTION="Perl DES encryption module"
+
+LICENSE="DES"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( dev-perl/Crypt-CBC )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}