summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-Curve25519/Crypt-Curve25519-0.60.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Crypt-Curve25519/Crypt-Curve25519-0.60.0-r1.ebuild')
-rw-r--r--dev-perl/Crypt-Curve25519/Crypt-Curve25519-0.60.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Curve25519/Crypt-Curve25519-0.60.0-r1.ebuild b/dev-perl/Crypt-Curve25519/Crypt-Curve25519-0.60.0-r1.ebuild
new file mode 100644
index 000000000000..aa77617383fd
--- /dev/null
+++ b/dev-perl/Crypt-Curve25519/Crypt-Curve25519-0.60.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=AJGB
+DIST_VERSION=0.06
+inherit perl-module
+
+DESCRIPTION="Shared secret elliptic-curve Diffie-Hellman generator"
+LICENSE="|| ( Artistic GPL-1+ ) BSD CC-PD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fmul-fixedvar.patch"
+)
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}