summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.700.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.700.0-r2.ebuild')
-rw-r--r--dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.700.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.700.0-r2.ebuild b/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.700.0-r2.ebuild
new file mode 100644
index 000000000000..19885fe803ac
--- /dev/null
+++ b/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.700.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DANIEL
+DIST_VERSION=1.7
+inherit perl-module
+
+DESCRIPTION="Perl interface to Alec Muffett's Cracklib"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="sys-libs/cracklib"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-CFLAGS.patch" )
+
+src_prepare() {
+ use test && perl_rm_files t/pod-coverage.t t/pod.t
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}