summaryrefslogtreecommitdiff
path: root/dev-perl/Cookie-Baker-XS/Cookie-Baker-XS-0.110.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Cookie-Baker-XS/Cookie-Baker-XS-0.110.0.ebuild')
-rw-r--r--dev-perl/Cookie-Baker-XS/Cookie-Baker-XS-0.110.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Cookie-Baker-XS/Cookie-Baker-XS-0.110.0.ebuild b/dev-perl/Cookie-Baker-XS/Cookie-Baker-XS-0.110.0.ebuild
new file mode 100644
index 000000000000..1fbe05d444dd
--- /dev/null
+++ b/dev-perl/Cookie-Baker-XS/Cookie-Baker-XS-0.110.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=KAZEBURO
+DIST_VERSION=0.11
+inherit perl-module
+
+DESCRIPTION="Accelerate Cookie::Baker's crush_cookie"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Exporter
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ >=virtual/perl-Test-Simple-0.980.0
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}