summaryrefslogtreecommitdiff
path: root/dev-perl/Convert-Binary-C
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Convert-Binary-C')
-rw-r--r--dev-perl/Convert-Binary-C/Manifest1
-rw-r--r--dev-perl/Convert-Binary-C/files/Convert-Binary-C-0.780.0-perl-526.patch181
2 files changed, 0 insertions, 182 deletions
diff --git a/dev-perl/Convert-Binary-C/Manifest b/dev-perl/Convert-Binary-C/Manifest
index f1b72c776e9b..37d3054c7d3f 100644
--- a/dev-perl/Convert-Binary-C/Manifest
+++ b/dev-perl/Convert-Binary-C/Manifest
@@ -1,4 +1,3 @@
-AUX Convert-Binary-C-0.780.0-perl-526.patch 5389 BLAKE2B 458c7dedc257f04d79edc1fa49dadeb72393874c1956ea8d7c8f382e81f5131691a5f7120b340437efa8278928403469b5b1a76157822e5438b82888cbcc6f9c SHA512 c6bffca0fe3bdf47d32821f6fff033828f03c4a26e23c4097556f0134a40e01bc47cae5672707cd875f11b9f63a1877b096eec76349e35e99ba4a1c4284aad4a
DIST Convert-Binary-C-0.84.tar.gz 1348549 BLAKE2B 7271f68d26cd387aa75c2eb966bd8497081e690ed7bd1339c98864fe9349398c723dab26120ecdaf534f28a969e85df95aa9ff7bbde8e4f1146a4a9b79818f1e SHA512 1c5160b39e5b64dc61c5e6bfeb163728352721ebfdc8c5096557e19293136e0aea613bf166e9b539a3980c39bc98466c99691be7d4f7325dac0c05fdd324440d
EBUILD Convert-Binary-C-0.840.0.ebuild 577 BLAKE2B 1b04ae98e1ed890edf70feaafebcf592d591c825ca75c7470212edc39080f53f1588516e42e39f819b6740235fa921b5d94e23bdbbf5ea0d5b2da884fcf459ed SHA512 aaadf52ee3eed1f147e421e04f604dde838e18b8b2e54b52306b026034db71c1b929ac7c727e7b1857444baf10336172a5a11da41a8dc53b372c97f5df984f7d
MISC metadata.xml 478 BLAKE2B 0dab96e21fa8a982057859969e3ff5be89591a8141365a55abab6b12165243c20f81ba724af8fb5f1d0364face2606724567aa4d03cb2975eac7e5a554889f23 SHA512 589fee143714f35bf258db7a23b2d7539dd311b891f1c5132a8018f911296aa38fa45237a72be8fcbe38b890fb401d60bcb380cd1793eccfbc4287c114c0cda5
diff --git a/dev-perl/Convert-Binary-C/files/Convert-Binary-C-0.780.0-perl-526.patch b/dev-perl/Convert-Binary-C/files/Convert-Binary-C-0.780.0-perl-526.patch
deleted file mode 100644
index 2c61d6178bc5..000000000000
--- a/dev-perl/Convert-Binary-C/files/Convert-Binary-C-0.780.0-perl-526.patch
+++ /dev/null
@@ -1,181 +0,0 @@
-From 26c2c60f11cf649f348a5af2c15f83525f02bf30 Mon Sep 17 00:00:00 2001
-From: Kent Fredric <kentfredric@gmail.com>
-Date: Wed, 20 Sep 2017 08:00:50 +1200
-Subject: Fix tests for Perl 5.26
-
-Bug: https://rt.cpan.org/Public/Bug/Display.html?id=121039
-Bug: https://bugs.gentoo.org/615106
-Bug: https://github.com/mhx/Convert-Binary-C/pull/6
----
- bin/perltypes.PL | 3 ++-
- tests/206_parse.t | 4 ++--
- tests/209_sourcify.t | 2 +-
- tests/210_depend.t | 2 +-
- tests/211_clone.t | 2 +-
- tests/215_local.t | 2 +-
- tests/218_member.t | 2 +-
- tests/223_initializer.t | 2 +-
- tests/230_compiler.t | 2 +-
- tests/601_speed.t | 2 +-
- tests/602_threads.t | 2 +-
- 11 files changed, 13 insertions(+), 12 deletions(-)
-
-diff --git a/bin/perltypes.PL b/bin/perltypes.PL
-index 09ca5d2..be63ffd 100755
---- a/bin/perltypes.PL
-+++ b/bin/perltypes.PL
-@@ -21,10 +21,11 @@ print OUT <<'!NO!SUBS!';
-
- use Convert::Binary::C;
- use Data::Dumper;
-+use File::Spec::Functions qw(rel2abs);
- use strict;
-
- my $base;
---d "$_/include" and $base = "$_/include" and last for qw( tests ../tests );
-+-d "$_/include" and $base = rel2abs("$_/include") and last for qw( tests ../tests );
- defined $base or die <<MSG;
- Please run this script from either the 'examples' directory
- or the distribution base directory.
-diff --git a/tests/206_parse.t b/tests/206_parse.t
-index 6e34d63..a4c403f 100644
---- a/tests/206_parse.t
-+++ b/tests/206_parse.t
-@@ -13,7 +13,7 @@ $^W = 1;
-
- BEGIN { plan tests => 116 }
-
--my $CCCFG = require 'tests/include/config.pl';
-+my $CCCFG = require './tests/include/config.pl';
-
- #===================================================================
- # create object (1 tests)
-@@ -140,7 +140,7 @@ ok($s1,329,"incorrect number of typedef identifiers");
- # check if all sizes are correct (1 big test)
- #===================================================================
-
--do 'tests/include/sizeof.pl';
-+do './tests/include/sizeof.pl';
- $max_size = 0;
- @fail = ();
- @success = ();
-diff --git a/tests/209_sourcify.t b/tests/209_sourcify.t
-index 3fbdae6..0f34e83 100644
---- a/tests/209_sourcify.t
-+++ b/tests/209_sourcify.t
-@@ -13,7 +13,7 @@ $^W = 1;
-
- BEGIN { plan tests => 98 }
-
--my $CCCFG = require 'tests/include/config.pl';
-+my $CCCFG = require './tests/include/config.pl';
-
- eval {
- $orig = new Convert::Binary::C %$CCCFG;
-diff --git a/tests/210_depend.t b/tests/210_depend.t
-index b46fdf7..e2705fd 100644
---- a/tests/210_depend.t
-+++ b/tests/210_depend.t
-@@ -13,7 +13,7 @@ $^W = 1;
-
- BEGIN { plan tests => 483 }
-
--my $CCCFG = require 'tests/include/config.pl';
-+my $CCCFG = require './tests/include/config.pl';
-
- eval {
- $c1 = new Convert::Binary::C Include => ['tests/include/files'];
-diff --git a/tests/211_clone.t b/tests/211_clone.t
-index 252554f..144de70 100644
---- a/tests/211_clone.t
-+++ b/tests/211_clone.t
-@@ -13,7 +13,7 @@ $^W = 1;
-
- BEGIN { plan tests => 35 }
-
--my $CCCFG = require 'tests/include/config.pl';
-+my $CCCFG = require './tests/include/config.pl';
-
- eval {
- $orig = new Convert::Binary::C %$CCCFG;
-diff --git a/tests/215_local.t b/tests/215_local.t
-index dabf7fc..2f2dffe 100644
---- a/tests/215_local.t
-+++ b/tests/215_local.t
-@@ -15,7 +15,7 @@ BEGIN {
- plan tests => 10;
- }
-
--my $CCCFG = require 'tests/include/config.pl';
-+my $CCCFG = require './tests/include/config.pl';
-
- eval {
- $c = new Convert::Binary::C;
-diff --git a/tests/218_member.t b/tests/218_member.t
-index e212160..7966e44 100644
---- a/tests/218_member.t
-+++ b/tests/218_member.t
-@@ -15,7 +15,7 @@ BEGIN {
- plan tests => 1907;
- }
-
--my $CCCFG = require 'tests/include/config.pl';
-+my $CCCFG = require './tests/include/config.pl';
-
- %basic = ( char => 1, short => 1, int => 1,
- long => 1, signed => 1, unsigned => 1,
-diff --git a/tests/223_initializer.t b/tests/223_initializer.t
-index a80d741..f1d6b26 100644
---- a/tests/223_initializer.t
-+++ b/tests/223_initializer.t
-@@ -13,7 +13,7 @@ $^W = 1;
-
- BEGIN { plan tests => 27 }
-
--my $CCCFG = require 'tests/include/config.pl';
-+my $CCCFG = require './tests/include/config.pl';
-
- $c = eval { new Convert::Binary::C %$CCCFG };
- ok($@,'',"failed to create Convert::Binary::C objects");
-diff --git a/tests/230_compiler.t b/tests/230_compiler.t
-index 1cc67f1..276275a 100644
---- a/tests/230_compiler.t
-+++ b/tests/230_compiler.t
-@@ -37,7 +37,7 @@ for my $cur (sort keys %cc) {
- $bin =~ s/\s+//gms;
- $bin = pack "H*", $bin;
-
-- do $cc{$cur}{cfg};
-+ do "./$cc{$cur}{cfg}";
-
- my $c = new Convert::Binary::C %config;
- $c->parse_file('tests/compiler/test.h');
-diff --git a/tests/601_speed.t b/tests/601_speed.t
-index 27f1fc9..d399e38 100644
---- a/tests/601_speed.t
-+++ b/tests/601_speed.t
-@@ -16,7 +16,7 @@ BEGIN {
- plan tests => 11;
- }
-
--my $CCCFG = require 'tests/include/config.pl';
-+my $CCCFG = require './tests/include/config.pl';
-
- eval { require Data::Dumper }; $Data_Dumper = $@;
- eval { require IO::File }; $IO_File = $@;
-diff --git a/tests/602_threads.t b/tests/602_threads.t
-index 8e45b0d..968939b 100644
---- a/tests/602_threads.t
-+++ b/tests/602_threads.t
-@@ -17,7 +17,7 @@ BEGIN {
- plan tests => NUM_THREADS
- }
-
--my $CCCFG = require 'tests/include/config.pl';
-+my $CCCFG = require './tests/include/config.pl';
-
- #===================================================================
- # load appropriate threads module and start a couple of threads
---
-2.14.1
-