summaryrefslogtreecommitdiff
path: root/dev-perl/CGI-Simple/CGI-Simple-1.280.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/CGI-Simple/CGI-Simple-1.280.0.ebuild')
-rw-r--r--dev-perl/CGI-Simple/CGI-Simple-1.280.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/CGI-Simple/CGI-Simple-1.280.0.ebuild b/dev-perl/CGI-Simple/CGI-Simple-1.280.0.ebuild
new file mode 100644
index 000000000000..6d797f120962
--- /dev/null
+++ b/dev-perl/CGI-Simple/CGI-Simple-1.280.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MANWAR
+DIST_VERSION=1.280
+inherit perl-module
+
+DESCRIPTION="A Simple totally OO CGI interface that is CGI.pm compliant"
+# Bug: https://bugs.gentoo.org/721422
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="
+ dev-perl/Module-Build
+ test? (
+ dev-perl/libwww-perl
+ dev-perl/IO-stringy
+ virtual/perl-File-Temp
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ )
+"