summaryrefslogtreecommitdiff
path: root/dev-perl/CDB_File/CDB_File-1.50.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/CDB_File/CDB_File-1.50.0.ebuild')
-rw-r--r--dev-perl/CDB_File/CDB_File-1.50.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-perl/CDB_File/CDB_File-1.50.0.ebuild b/dev-perl/CDB_File/CDB_File-1.50.0.ebuild
new file mode 100644
index 000000000000..98e9fab12458
--- /dev/null
+++ b/dev-perl/CDB_File/CDB_File-1.50.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TODDR
+DIST_VERSION=1.05
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Perl extension for access to cdb databases"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/B-COW
+ virtual/perl-File-Temp
+ virtual/perl-Test-Simple
+ )
+"
+
+# Parallel breaks
+DIST_TEST="do"
+
+src_prepare() {
+ mkdir "${S}/examples" || die "Can't make examples dir"
+ einfo "Moving bun-x.pl to examples/"
+ cp "${S}/bun-x.pl" "${S}/examples/" || die "Can't copy example to examples/"
+ perl_rm_files bun-x.pl
+ perl-module_src_prepare
+}
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}