summaryrefslogtreecommitdiff
path: root/dev-perl/CBOR-XS/CBOR-XS-1.830.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/CBOR-XS/CBOR-XS-1.830.0.ebuild')
-rw-r--r--dev-perl/CBOR-XS/CBOR-XS-1.830.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/CBOR-XS/CBOR-XS-1.830.0.ebuild b/dev-perl/CBOR-XS/CBOR-XS-1.830.0.ebuild
new file mode 100644
index 000000000000..11a8ea2bd88c
--- /dev/null
+++ b/dev-perl/CBOR-XS/CBOR-XS-1.830.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=1.83
+
+inherit perl-module
+
+DESCRIPTION="Concise Binary Object Representation (CBOR, RFC7049)"
+# License note: see bottom of ecb.h license block
+LICENSE="GPL-3 || ( GPL-2+ BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Types-Serialiser
+ dev-perl/common-sense
+"
+DEPEND="${RDEPEND}
+ dev-perl/Canary-Stability
+ >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+"
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}