summaryrefslogtreecommitdiff
path: root/dev-perl/B-Utils
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/B-Utils')
-rw-r--r--dev-perl/B-Utils/B-Utils-0.270.0-r2.ebuild41
-rw-r--r--dev-perl/B-Utils/Manifest1
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/B-Utils/B-Utils-0.270.0-r2.ebuild b/dev-perl/B-Utils/B-Utils-0.270.0-r2.ebuild
new file mode 100644
index 000000000000..873e3bd16ee1
--- /dev/null
+++ b/dev-perl/B-Utils/B-Utils-0.270.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.27
+inherit perl-module
+
+DESCRIPTION="Helper functions for op tree manipulation"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# needs Scalar::Util
+RDEPEND="
+ virtual/perl-Exporter
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Task-Weaken
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/ExtUtils-Depends-0.301.0
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ # These useless no-op tests that simply clutter test output
+ t/utils/{31oldname,32kids,33ancestors,34descendants,35siblings,36previous,37stringify}.t
+ t/utils/{41walkfilt,42all,43allfilt,44optrep}.t
+ t/utils/{50carp,51croak}.t
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/B-Utils/Manifest b/dev-perl/B-Utils/Manifest
index 6cc34ad87266..25561eb6ba0e 100644
--- a/dev-perl/B-Utils/Manifest
+++ b/dev-perl/B-Utils/Manifest
@@ -1,4 +1,5 @@
DIST B-Utils-0.27.tar.gz 74612 BLAKE2B 4bac004543111890385dc0ba59fd73f25f4d3aea169c243487144deafe99c114f9783b4271570f3c2f40566f73767bc414818396d786c46d8b9fae9977c18b0f SHA512 a896476f59a424fa9062c5dfe6431493c020e51746fa7f7b4c7fcdb109d1c0fa252292b891263d676884f064db95f16958a5d2ed5981dc5997436dced6579e74
EBUILD B-Utils-0.270.0-r1.ebuild 821 BLAKE2B cfc16783c3582afa479a563ba4eed53b34121e2f38587d3d9bc5d9827bd23589c96ae193723d01aac7722922c82afd312206eb2503de272160d5a0e4dee47290 SHA512 ac4ce4242f97cc984b1ca9d9fb09ae44b39be08a340f33b36d642515b9bbb9e30d958e0a0bf899107b425144c8e561d75dde2402b23e80411aba7b9a0e2279d3
+EBUILD B-Utils-0.270.0-r2.ebuild 900 BLAKE2B 9966863476476a6ac614a101ae6e60a225429c63d9a3c0f4e6de086767a7b3d1f97de5f1de3e1e6c02ff9632d9d95b4615baa31306206b3ff96e8ced5652e1a5 SHA512 f228607ee4f1993a0e8da9d58e10936ee4b19d30b84f4554169bcf84b16ce2a52597d9447f8370f3f7b6134037109be049a90e72545fe20c5983633df9f4e439
EBUILD B-Utils-0.270.0.ebuild 597 BLAKE2B a00e4c653ba63405a55c505d66bcb67e0b9634cd6eff62b4dd9a1f387ad5c3f0d16a346c8d864973c40a08d7ac4731e9c3851d41c88e851b9ed2139d1e54c886 SHA512 5825b851cd32f23c2ef2ab103c2f9ca3d0f583e3a652c0a95c29a86c58ea20715ef288b03aec8ded1c5cf66e022a554a5cee1a19c352a912334c75cbaed5876d
MISC metadata.xml 516 BLAKE2B ce01b0c9312075c7a18827aa76d9d2a20a22fc5145b50613873bf41c823342861a2596f01d32afc2ec18b7e54f3fb8fa8198927e8af2165efbf18faee0e1e98f SHA512 56897978c780a0a89075476786016ed76832a25d724f88c0f99f209ca57c8785f3db65a9f13aeae8f9af57e8c13018d7c35d52f1dd744bd0fd12846c68bde53c