summaryrefslogtreecommitdiff
path: root/dev-perl/B-COW/B-COW-0.4.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/B-COW/B-COW-0.4.0-r1.ebuild')
-rw-r--r--dev-perl/B-COW/B-COW-0.4.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/B-COW/B-COW-0.4.0-r1.ebuild b/dev-perl/B-COW/B-COW-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..b621e4cce325
--- /dev/null
+++ b/dev-perl/B-COW/B-COW-0.4.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ATOOMIC
+DIST_VERSION=0.004
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="additional B helpers to check COW status"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}