summaryrefslogtreecommitdiff
path: root/dev-perl/Authen-Radius
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Authen-Radius')
-rw-r--r--dev-perl/Authen-Radius/Authen-Radius-0.220.0-r1.ebuild44
-rw-r--r--dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild48
-rw-r--r--dev-perl/Authen-Radius/Manifest8
-rw-r--r--dev-perl/Authen-Radius/files/Authen-Radius-0.26-cisco-dictionary.patch28
-rw-r--r--dev-perl/Authen-Radius/files/Authen-Radius-0.26-no-install-db.patch43
-rw-r--r--dev-perl/Authen-Radius/files/dictionary.cisco.ssg.patch14
-rw-r--r--dev-perl/Authen-Radius/metadata.xml12
7 files changed, 197 insertions, 0 deletions
diff --git a/dev-perl/Authen-Radius/Authen-Radius-0.220.0-r1.ebuild b/dev-perl/Authen-Radius/Authen-Radius-0.220.0-r1.ebuild
new file mode 100644
index 000000000000..157df28ca9cd
--- /dev/null
+++ b/dev-perl/Authen-Radius/Authen-Radius-0.220.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PN=RadiusPerl
+MODULE_AUTHOR=MANOWAR
+MODULE_VERSION=0.22
+inherit perl-module
+
+DESCRIPTION="Communicate with a Radius server from Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~sparc x86"
+IUSE=""
+
+DEPEND="
+ >=virtual/perl-Digest-MD5-2.200.0
+ >=virtual/perl-IO-1.12
+ >=dev-perl/Data-HexDump-0.02
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/Authen-Radius-${MODULE_VERSION}
+
+SRC_TEST="do"
+export OPTIMIZE="$CFLAGS"
+PATCHES=( "${FILESDIR}"/dictionary.cisco.ssg.patch )
+
+src_prepare() {
+ sed -i '/install-radius-db.PL/d' Makefile.PL MANIFEST || die
+ mv "${S}"/install-radius-db.PL{,.orig} || die
+
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Really want to install these radius dictionaries?
+ insinto /etc/raddb
+ doins raddb/dictionary*
+}
diff --git a/dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild b/dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild
new file mode 100644
index 000000000000..93ca6b83ed0f
--- /dev/null
+++ b/dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PORTAONE
+DIST_VERSION=0.26
+inherit perl-module
+
+DESCRIPTION="Communicate with a Radius server from Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Data-Dumper-1.0.0
+ >=dev-perl/Data-HexDump-0.20.0
+ >=virtual/perl-Digest-MD5-2.200.0
+ >=virtual/perl-IO-1.120.0
+ >=dev-perl/Net-IP-1.260.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ dev-perl/Test-NoWarnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.26-cisco-dictionary.patch
+ "${FILESDIR}"/${PN}-0.26-no-install-db.patch
+)
+
+src_configure() {
+ export OPTIMIZE="$CFLAGS"
+ perl-module_src_configure
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Really want to install these radius dictionaries?
+ insinto /etc/raddb
+ doins raddb/dictionary*
+}
diff --git a/dev-perl/Authen-Radius/Manifest b/dev-perl/Authen-Radius/Manifest
new file mode 100644
index 000000000000..702bf30cf0ac
--- /dev/null
+++ b/dev-perl/Authen-Radius/Manifest
@@ -0,0 +1,8 @@
+AUX Authen-Radius-0.26-cisco-dictionary.patch 1176 BLAKE2B a090393a57ee39c06345d0969f5c54de30158265fd548fbe88d7dfd40335523c9ef3c9c5d5ae6432796d992c4f19e793544013bbdb7f9c5cc7854a66ae5a15c6 SHA512 f040137ade128614a0f35fe016a58989e3d5bf8fdc2ed20358223fd5ac4792d72edc135e0c1a4335be3f66d38e0120d8d42950266def30b273484ed6bda66b4c
+AUX Authen-Radius-0.26-no-install-db.patch 1234 BLAKE2B 004c2fefaf43efedfcf92bacff4139795a66c06394984f2c5cda14951214d0fdb97a84f4fbe9617b991a052091281037fcfb2592df0a620c4b8090c9365c5eca SHA512 ee947157e5bb02ccb171554d5b83e44482f0fc44b5d2c1e3d3488943baa175a87950999930ea79dd087c731b145ee15bcf394d784cbcabcd73a2f4ef8362b485
+AUX dictionary.cisco.ssg.patch 789 BLAKE2B 4938aeb59610915926a1aae3b334e5373e5fe34373ed40f3bcdef51777a838fcc95bdb93f5878393c1403e4490f74d4ca68926ea1482f6cc85d14846536bd658 SHA512 78497de611aaf280c8d4291776219489b678f9cd479fe3f2ae4c61d8e512f448435da5e77eff14d5a40a0d73e626d70c55e1fa6f932d13daa2c330235e6fe4cf
+DIST Authen-Radius-0.26.tar.gz 49432 BLAKE2B 05ce64cf463faa1ad1004a659859961d6df24d0651a180603a5a5fc3d672a91f8df521f7d19bbc7b62aa0d63e1ae5b54dec3d46718973ee160f3e7bae5f15d02 SHA512 6779712cd4fdc45115c6e68766ef58c8b1dc9bf3037f3e0e243bc23318d13b09104df5f825b40ce26f7eebe52e6c4887efc8525334f2ab00da23fe76322f0b56
+DIST RadiusPerl-0.22.tar.gz 40980 BLAKE2B 5c8a1870d7a95c89f9f2b8546c0285b5cf62873b3960ee67d45db3c9edfa0117fc40f3238d42a1306a15c4740e739381ae7bb88234bfceff2a79d73a84e384f1 SHA512 d5c7327fa3d4b6f74405e905f01be23479be542073d035c3babc34b63577069f6069e44dda9709b69b5dc25552170a764eb02ab6d2b6c2f7b366da566ae8e967
+EBUILD Authen-Radius-0.220.0-r1.ebuild 884 BLAKE2B 3a97c8502806a2800c04ac312fb54001262434e3aaa707859b1135f95f0a1787fe0e74b95fd0605188f46fe357b1f4df2951b987c1a2f456839ec4f18d2da518 SHA512 f6368a005029dccaee9e82fef1da4569a0fe836bfba3bf114b22387c818764f1f0407cc746bdf5517c881d3a2c523119912f499e84784a5a86489407ecb13bfb
+EBUILD Authen-Radius-0.260.0.ebuild 936 BLAKE2B 86a74eb4f5357b6a9639e27ae244a6905abb259a8602230ad9718f542d4ac8920791c7da1e842d9b0cfe26d803ad98bdeb7e6bf69fd02e445e3c77c4d6b69958 SHA512 0751ec8b173458084a79f20e2c022d8b5e7c8cd192de08527b7af6593894bb02dc5954ac9b7555fba90c8606c469277a2dac410dd9d8a428a96ed305b456c202
+MISC metadata.xml 398 BLAKE2B e4d3554055d85f7488c0b8e71da8792d7e86560ffe3cfd3037caf69e708f777ffc6e9044d76228463b71c82ad1ca85230e1aec637140fdc2ffe3f9042344acbd SHA512 780392f67556558208d30f88e4bb2ea9c58acbeb250bb01df4de7b9d1cc90e6d17634c4447cb7f779fd1748be3c363b280cac716b250a66c7d1cc1dd349a4ece
diff --git a/dev-perl/Authen-Radius/files/Authen-Radius-0.26-cisco-dictionary.patch b/dev-perl/Authen-Radius/files/Authen-Radius-0.26-cisco-dictionary.patch
new file mode 100644
index 000000000000..19d6b0ed9ca1
--- /dev/null
+++ b/dev-perl/Authen-Radius/files/Authen-Radius-0.26-cisco-dictionary.patch
@@ -0,0 +1,28 @@
+From c3955cd5e9232cf891500cdddf96c0f4e336029b Mon Sep 17 00:00:00 2001
+From: Patrick Lauer <patrick@gentoo.org>
+Date: Mon, 29 Oct 2012 21:02:39 +1300
+Subject: Add ISG support to raddb cisco dictionary
+
+---
+ raddb/dictionary.cisco | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/raddb/dictionary.cisco b/raddb/dictionary.cisco
+index 4dadaa3..8d57a03 100644
+--- a/raddb/dictionary.cisco
++++ b/raddb/dictionary.cisco
+@@ -118,3 +118,11 @@ VALUE Cisco-Disconnect-Cause Session-Failed-Security 101
+ VALUE Cisco-Disconnect-Cause Session-End-Callback 102
+ VALUE Cisco-Disconnect-Cause Invalid-Protocol 120
+
++#ISG Support http://www.cisco.com/en/US/docs/ios/12_2sb/isg/coa/guide/isgcaapa.html
++ATTRIBUTE Cisco-Policy-Up 37 string Cisco
++ATTRIBUTE Cisco-Policy-Down 38 string Cisco
++ATTRIBUTE Cisco-SSG-Subscriber-Password 249 string Cisco
++ATTRIBUTE Cisco-SSG-Account-Info 250 string Cisco
++ATTRIBUTE Cisco-SSG-Service-Info 251 string Cisco
++ATTRIBUTE Cisco-SSG-Command-Code 252 string Cisco
++ATTRIBUTE Cisco-SSG-Control-Info 253 string Cisco
+--
+2.15.1
+
diff --git a/dev-perl/Authen-Radius/files/Authen-Radius-0.26-no-install-db.patch b/dev-perl/Authen-Radius/files/Authen-Radius-0.26-no-install-db.patch
new file mode 100644
index 000000000000..746ba993defc
--- /dev/null
+++ b/dev-perl/Authen-Radius/files/Authen-Radius-0.26-no-install-db.patch
@@ -0,0 +1,43 @@
+From 57b9f1a710c2eee1c8f54eb87d164584aa9532ce Mon Sep 17 00:00:00 2001
+From: Torsten Veller <tove@gentoo.org>
+Date: Mon, 5 Nov 2012 01:02:48 +1300
+Subject: Remove automatic radis-db installer code
+
+---
+ MANIFEST | 1 -
+ Makefile.PL | 1 -
+ install-radius-db.PL => install-radius-db.PL.orig | 0
+ 3 files changed, 2 deletions(-)
+ rename install-radius-db.PL => install-radius-db.PL.orig (100%)
+
+diff --git a/MANIFEST b/MANIFEST
+index a8e2801..09913da 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -4,7 +4,6 @@ README
+ LICENSE
+ MANIFEST
+ Radius.pm
+-install-radius-db.PL
+ t/decode.t
+ t/dictionary.t
+ t/digest.t
+diff --git a/Makefile.PL b/Makefile.PL
+index 45653ab..7f1b202 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -4,7 +4,6 @@ use ExtUtils::MakeMaker;
+ WriteMakefile(
+ NAME => 'Authen::Radius',
+ VERSION_FROM => 'Radius.pm', # finds $VERSION
+- PPM_INSTALL_SCRIPT => 'install-radius-db.PL',
+ MIN_PERL_VERSION => "v5.10",
+ BUILD_REQUIRES => {
+ # Support for TEST_REQUIRES
+diff --git a/install-radius-db.PL b/install-radius-db.PL.orig
+similarity index 100%
+rename from install-radius-db.PL
+rename to install-radius-db.PL.orig
+--
+2.15.1
+
diff --git a/dev-perl/Authen-Radius/files/dictionary.cisco.ssg.patch b/dev-perl/Authen-Radius/files/dictionary.cisco.ssg.patch
new file mode 100644
index 000000000000..bbec7052ff67
--- /dev/null
+++ b/dev-perl/Authen-Radius/files/dictionary.cisco.ssg.patch
@@ -0,0 +1,14 @@
+--- /etc/raddb/dictionary.cisco 2010-02-10 01:04:00.000000000 +0200
++++ dictionary.cisco 2010-02-10 01:06:10.000000000 +0200
+@@ -118,3 +118,11 @@
+ VALUE Cisco-Disconnect-Cause Session-End-Callback 102
+ VALUE Cisco-Disconnect-Cause Invalid-Protocol 120
+
++#ISG Support http://www.cisco.com/en/US/docs/ios/12_2sb/isg/coa/guide/isgcaapa.html
++ATTRIBUTE Cisco-Policy-Up 37 string Cisco
++ATTRIBUTE Cisco-Policy-Down 38 string Cisco
++ATTRIBUTE Cisco-SSG-Subscriber-Password 249 string Cisco
++ATTRIBUTE Cisco-SSG-Account-Info 250 string Cisco
++ATTRIBUTE Cisco-SSG-Service-Info 251 string Cisco
++ATTRIBUTE Cisco-SSG-Command-Code 252 string Cisco
++ATTRIBUTE Cisco-SSG-Control-Info 253 string Cisco
diff --git a/dev-perl/Authen-Radius/metadata.xml b/dev-perl/Authen-Radius/metadata.xml
new file mode 100644
index 000000000000..d5df1a58b810
--- /dev/null
+++ b/dev-perl/Authen-Radius/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Authen-Radius</remote-id>
+ <remote-id type="cpan-module">Authen::Radius</remote-id>
+ </upstream>
+</pkgmetadata>