summaryrefslogtreecommitdiff
path: root/dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0-r1.ebuild')
-rw-r--r--dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0-r1.ebuild b/dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0-r1.ebuild
new file mode 100644
index 000000000000..ae89dcc461ce
--- /dev/null
+++ b/dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DMUEY
+DIST_VERSION=0.23
+DIST_EXAMPLES=("example.pl")
+inherit perl-module
+
+DESCRIPTION="A Perl access to the TCP Wrappers interface"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/tcp-wrappers"
+DEPEND="dev-perl/Module-Build"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.420.0
+ virtual/perl-ExtUtils-CBuilder
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Exception
+ )
+"
+PERL_RM_FILES=(
+ t/03_pod.t
+ t/02_maintainer.t
+)
+src_configure() {
+ unset LD
+ if [[ -n "${CCLD}" ]]; then
+ export LD="${CCLD}"
+ fi
+ perl-module_src_configure
+}
+src_compile() {
+ ./Build --config optimize="${CFLAGS}" build || die
+}