summaryrefslogtreecommitdiff
path: root/dev-perl/Audio-DSP/Audio-DSP-0.20.0-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Audio-DSP/Audio-DSP-0.20.0-r3.ebuild')
-rw-r--r--dev-perl/Audio-DSP/Audio-DSP-0.20.0-r3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/Audio-DSP/Audio-DSP-0.20.0-r3.ebuild b/dev-perl/Audio-DSP/Audio-DSP-0.20.0-r3.ebuild
new file mode 100644
index 000000000000..1996d7d88343
--- /dev/null
+++ b/dev-perl/Audio-DSP/Audio-DSP-0.20.0-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SETHJ
+DIST_VERSION=0.02
+inherit perl-module
+
+DESCRIPTION="Perl interface to *NIX digital audio device"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+src_test() {
+ local MODULES=(
+ "Audio::DSP ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ if [[ "${AUDIO_DSP_HW_TEST:-0}" == 0 ]]; then
+ ewarn "Comprehensive testing of this module needs hardware access to dsp"
+ ewarn "devices. Set AUDIO_DSP_HW_TEST=1 in your environment if you want full"
+ ewarn "coverage"
+ ewarn "For details, see:"
+ ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/Audio-DSP"
+ else
+ perl-module_src_test
+ fi
+}