summaryrefslogtreecommitdiff
path: root/dev-ml/zed/zed-3.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/zed/zed-3.2.1.ebuild')
-rw-r--r--dev-ml/zed/zed-3.2.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/zed/zed-3.2.1.ebuild b/dev-ml/zed/zed-3.2.1.ebuild
new file mode 100644
index 000000000000..91421c5d8ec0
--- /dev/null
+++ b/dev-ml/zed/zed-3.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Abstract engine for text edition in OCaml"
+HOMEPAGE="https://github.com/ocaml-community/zed"
+SRC_URI="https://github.com/ocaml-community/zed/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/camomile:=
+ dev-ml/charinfo_width:=
+ dev-ml/react:=
+ dev-ml/uuseg:=
+"
+DEPEND="${RDEPEND}"