summaryrefslogtreecommitdiff
path: root/dev-ml/zarith
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/zarith')
-rw-r--r--dev-ml/zarith/Manifest2
-rw-r--r--dev-ml/zarith/zarith-1.14.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-ml/zarith/Manifest b/dev-ml/zarith/Manifest
index e9af2ee347eb..9c25541f94d7 100644
--- a/dev-ml/zarith/Manifest
+++ b/dev-ml/zarith/Manifest
@@ -1,3 +1,5 @@
DIST zarith-1.13.tar.gz 85994 BLAKE2B a5860319e17f4e660f248f3e724076b578d27dc3a06e8b54d68bcd6ed021a0354ad714dfcb06329bb9c4a3eadc3d08fd84fd76ef5d1a8902a06a7506d77addde SHA512 a562fa8bf4f5ef44f2af6b9a8f028182fd184c89f8c41455acdc02851cc0fc3124d3776c0de930e8d09cd5d6d88cc689f80f4b597068a0611131f45d057b101f
+DIST zarith-1.14.tar.gz 91788 BLAKE2B e00b6ed0893a7a4b53c859edc02030336f1c35405202f87741d87288819bdb6562bb3728c6950074b625ad9e5a16cc4afd39c4e0e2486ba18f1a84e49339fdd3 SHA512 8a7f3e82dfa5699c8dda54dd5398c712f3ac4fe04f5208d43d8ba198fb8152de5f91cbb59c15c0a4ba010d4dfcc79f52e405bdd0abbf2798167e9e4216bcb3dd
EBUILD zarith-1.13.ebuild 1314 BLAKE2B ebeb8243c2f9a480cc32738008755fb96e7539994d6c6044f20b0e31bed709468c3d8e33a50db981d51294264172fa3796ebb6a24cae2fb15826fdfd41db2ece SHA512 c932c98f3e82ac10856eefb6e26fabea1af59a3119171bef64218cc09e63e85988b555133e8d6fe0365090b3b517ebdd8c3fde487a9547b2f2f3f3c833f15ef3
+EBUILD zarith-1.14.ebuild 1316 BLAKE2B da4fccff17c5875a57ea5e98499f91ae27a87545e032430528808150fa17ae1c09d5b539949cef6ecf34e3646fd717c062c9403ff07ccc76f291139e850d5edf SHA512 70a15ea10afbd9544368459a797f248aa69c59470343f5977d035dd59f494248bd5cda44d240d478dc6354dc19435d9c5cb253064bbf7780a8e9fa2517a165f7
MISC metadata.xml 310 BLAKE2B 07bd7620cfa9ef58a67cb51d22888d48e848ac1736d8bf0e58684adecf62754472a24249a6e7e27701b5b0be5497e2efff7cedaa7be4c884547fa48efb29eb06 SHA512 59adcb11592c882af95fdce2232c40efc52d9d15bc803657133672237799f7986246775dc714692cb9cac3c93ab8069873d8e05deae1dd2b40904ea7fc4c63b7
diff --git a/dev-ml/zarith/zarith-1.14.ebuild b/dev-ml/zarith/zarith-1.14.ebuild
new file mode 100644
index 000000000000..71653713a899
--- /dev/null
+++ b/dev-ml/zarith/zarith-1.14.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib toolchain-funcs
+
+DESCRIPTION="Arithmetic and logic operations over arbitrary-precision integers"
+HOMEPAGE="https://github.com/ocaml/Zarith"
+SRC_URI="https://github.com/ocaml/Zarith/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/Zarith-release-${PV}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="doc +ocamlopt"
+RESTRICT="!ocamlopt? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.05:=[ocamlopt=]
+ dev-libs/gmp:0=
+"
+DEPEND="${RDEPEND} dev-lang/perl"
+
+DOCS=( README.md Changes )
+
+src_configure() {
+ tc-export CC AR
+ ./configure \
+ -ocamllibdir /usr/$(get_libdir)/ocaml -gmp || die
+ sed -i \
+ -e 's|$(INSTALLDIR)|$(DESTDIR)$(INSTALLDIR)|g' \
+ project.mak || die
+}
+
+src_compile() {
+ emake -j 1 HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) all
+ use doc && emake doc
+}
+
+src_test() {
+ emake HASOCAMLOPT=yes HASDYNLINK=yes tests
+}
+
+src_install() {
+ findlib_src_preinst
+
+ emake \
+ HASOCAMLOPT=$(usex ocamlopt yes no) \
+ HASDYNLINK=$(usex ocamlopt yes no) \
+ DESTDIR="${ED}" \
+ install
+
+ dosym zarith/libzarith.a /usr/$(get_libdir)/ocaml/libzarith.a
+
+ use doc && HTML_DOCS=( html/* )
+ einstalldocs
+}