summaryrefslogtreecommitdiff
path: root/dev-ml/uunf/uunf-14.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/uunf/uunf-14.0.0.ebuild')
-rw-r--r--dev-ml/uunf/uunf-14.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/uunf/uunf-14.0.0.ebuild b/dev-ml/uunf/uunf-14.0.0.ebuild
new file mode 100644
index 000000000000..8d806d41586d
--- /dev/null
+++ b/dev-ml/uunf/uunf-14.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Unicode text normalization"
+HOMEPAGE="https://erratique.ch/software/uunf https://github.com/dbuenzli/uunf"
+SRC_URI="https://erratique.ch/software/uunf/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ml/topkg:=
+ dev-ml/uutf:=
+ dev-ml/cmdliner:="
+RDEPEND="${DEPEND}"
+BDEPEND="dev-ml/findlib"
+OPAM_FILE=opam
+
+src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ # bug #798270
+ ulimit -s 11530000
+
+ ocaml pkg/pkg.ml build \
+ || die
+}