summaryrefslogtreecommitdiff
path: root/dev-ml/uucp/uucp-13.0.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/uucp/uucp-13.0.0-r2.ebuild')
-rw-r--r--dev-ml/uucp/uucp-13.0.0-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/uucp/uucp-13.0.0-r2.ebuild b/dev-ml/uucp/uucp-13.0.0-r2.ebuild
new file mode 100644
index 000000000000..2dd9913cbd8d
--- /dev/null
+++ b/dev-ml/uucp/uucp-13.0.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Unicode character properties for OCaml"
+HOMEPAGE="https://erratique.ch/software/uucp https://github.com/dbuenzli/uucp"
+SRC_URI="https://erratique.ch/software/uucp/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ml/topkg
+ dev-ml/findlib"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-ml/ocamlbuild"
+OPAM_FILE=opam
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --with-uutf true \
+ --with-uunf false \
+ --with-cmdliner true \
+ || die
+}