summaryrefslogtreecommitdiff
path: root/dev-ml/uchar
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/uchar')
-rw-r--r--dev-ml/uchar/Manifest2
-rw-r--r--dev-ml/uchar/uchar-0.0.2-r1.ebuild (renamed from dev-ml/uchar/uchar-0.0.2.ebuild)19
2 files changed, 12 insertions, 9 deletions
diff --git a/dev-ml/uchar/Manifest b/dev-ml/uchar/Manifest
index cc9b959d3a02..d0acf205fa9a 100644
--- a/dev-ml/uchar/Manifest
+++ b/dev-ml/uchar/Manifest
@@ -1,3 +1,3 @@
DIST uchar-0.0.2.tar.gz 21815 BLAKE2B aede9d42ac2d9ccaa7af2f40799916f30cef0d6e292b7909b5131b5d28c979362b7624a88cec8ba2e7bed1dcada60d8e512ed70d2a02dafcf4ad701c60f6faa6 SHA512 487a9706cf9dfc9b9c94442a51766cc211687d6ebcb4dd3c94d09cb1ed6d7fd61e966e91a4121fe2d1681b2fd6bfee9079d3bccccdb6d65ba2111524ab5dd1bc
-EBUILD uchar-0.0.2.ebuild 1135 BLAKE2B cd979238c6e1e7f6d3cfbd4ac8e11ff36ffa3f24e105b15fe0512e67f5180055063debd996d982b2be679993f992906902965f0f3d0db466729ff95f230e05f1 SHA512 77a211337c7e7b645e5592fa10d08050cc904e3779faa8d6ced2ffedcbded9d8ff8997c6fb41748148a17ae1f92f8eeb0055b75f23e3f427d2d2ecfb6c72de9e
+EBUILD uchar-0.0.2-r1.ebuild 1156 BLAKE2B aa70426ff82349048bc042f2f96d327d1980a7b694fa062e9a93627a8db4cced7cd32fa183b03de95f4dbffefe7c8d900a0bddc226e901bf21591fbb223a0570 SHA512 9ab17f755680b57bd5374776473815843aaa578db017194ddf8571f17e5dfd1f346977fb8578e04a97628744c3660747ec5fa7e88417a1dac061bc1aa0917880
MISC metadata.xml 244 BLAKE2B 759275bc4a358cc6c10077647f9c8369f4003f790e9853d74431ead8da37125eac8d1e2c0db2bbfa050566ed4444bde6cf4ef0eba94fb62b247b68858925af63 SHA512 f3aebf1a2d4e468c378c7c5415dda77009fe0374f69828eadffb0077230108ce1c5ead5bce6095d8b6d1987f8e0c2db3c665d0a0175fcd496270f0086eee69a6
diff --git a/dev-ml/uchar/uchar-0.0.2.ebuild b/dev-ml/uchar/uchar-0.0.2-r1.ebuild
index b877cb8b70f8..e01cf3ceb62b 100644
--- a/dev-ml/uchar/uchar-0.0.2.ebuild
+++ b/dev-ml/uchar/uchar-0.0.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit findlib
+inherit edo findlib
DESCRIPTION="Uchar compatibility library"
HOMEPAGE="https://github.com/ocaml/uchar"
@@ -14,8 +14,9 @@ SLOT="0/${PV}"
KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv x86"
IUSE="+ocamlopt"
-RDEPEND=">=dev-lang/ocaml-4.03:="
-DEPEND="${RDEPEND} dev-ml/ocamlbuild"
+RDEPEND=">=dev-lang/ocaml-4.03:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/ocamlbuild"
# This is mostly a compat wrapper for older ocaml versions we don't support. No
# need to test it, plus it fails when installing for the first time:
@@ -23,19 +24,21 @@ DEPEND="${RDEPEND} dev-ml/ocamlbuild"
RESTRICT="test"
src_compile() {
- ocaml pkg/build.ml \
+ edo ocaml pkg/build.ml \
"native=$(usex ocamlopt true false)" \
- "native-dynlink=$(usex ocamlopt true false)" || die
+ "native-dynlink=$(usex ocamlopt true false)"
}
src_test() {
- ocamlbuild -X src -use-ocamlfind -pkg uchar test/testpkg.native || die
+ edo ocamlbuild -X src -use-ocamlfind -pkg uchar test/testpkg.native
}
src_install() {
# Can't use opam-installer here as it is an opam dep...
findlib_src_preinst
+
mv _build/pkg/META{.empty,} || die
ocamlfind install ${PN} _build/pkg/META || die
+
dodoc README.md CHANGES.md
}