summaryrefslogtreecommitdiff
path: root/dev-ml/stdio/stdio-0.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/stdio/stdio-0.14.0.ebuild')
-rw-r--r--dev-ml/stdio/stdio-0.14.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ml/stdio/stdio-0.14.0.ebuild b/dev-ml/stdio/stdio-0.14.0.ebuild
new file mode 100644
index 000000000000..3de25802f3b8
--- /dev/null
+++ b/dev-ml/stdio/stdio-0.14.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Standard IO Library for OCaml"
+HOMEPAGE="https://github.com/janestreet/stdio"
+SRC_URI="https://github.com/janestreet/stdio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-ml/base-0.11.0:=
+ dev-ml/sexplib0:="
+DEPEND="${RDEPEND}"