summaryrefslogtreecommitdiff
path: root/dev-ml/res/res-5.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/res/res-5.0.0.ebuild')
-rw-r--r--dev-ml/res/res-5.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/res/res-5.0.0.ebuild b/dev-ml/res/res-5.0.0.ebuild
new file mode 100644
index 000000000000..b503e1c2eed3
--- /dev/null
+++ b/dev-ml/res/res-5.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+DESCRIPTION="Resizable Array and Buffer modules for O'Caml"
+HOMEPAGE="http://mmottl.github.io/res/"
+SRC_URI="https://github.com/mmottl/res/releases/download/${PV}/${P}.tbz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ >=dev-ml/findlib-1.5"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_compile() {
+ jbuilder build @install || die
+}