summaryrefslogtreecommitdiff
path: root/dev-ml/re/re-1.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/re/re-1.7.1.ebuild')
-rw-r--r--dev-ml/re/re-1.7.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/re/re-1.7.1.ebuild b/dev-ml/re/re-1.7.1.ebuild
new file mode 100644
index 000000000000..2900f6f2fc5a
--- /dev/null
+++ b/dev-ml/re/re-1.7.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Regular expression library for OCaml"
+HOMEPAGE="https://github.com/ocaml/ocaml-re"
+SRC_URI="https://github.com/ocaml/ocaml-re/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!dev-ml/ocaml-re"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+DOCS=( "CHANGES" "TODO.txt" "README.md" )
+
+S="${WORKDIR}"/ocaml-${P}