summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.17.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.17.0.ebuild')
-rw-r--r--dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.17.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.17.0.ebuild b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.17.0.ebuild
new file mode 100644
index 000000000000..5c045f0ed8b7
--- /dev/null
+++ b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.17.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Support Library for type-driven code generators"
+HOMEPAGE="https://github.com/janestreet/ppx_sexp_conv"
+SRC_URI="https://github.com/janestreet/ppx_sexp_conv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/base:${SLOT}[ocamlopt?]
+ >=dev-ml/ppxlib-0.32.1:=[ocamlopt?]
+ dev-ml/ppxlib_jane:${SLOT}[ocamlopt?]
+ dev-ml/sexplib0:${SLOT}[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"