summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1-r1.ebuild')
-rw-r--r--dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1-r1.ebuild b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1-r1.ebuild
new file mode 100644
index 000000000000..fa923652fbc2
--- /dev/null
+++ b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="JSON codec generator for OCaml"
+HOMEPAGE="https://github.com/ocaml-ppx/ppx_deriving_yojson/"
+SRC_URI="https://github.com/ocaml-ppx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/ppxlib-0.20.0:=
+ dev-ml/ppx_deriving:=
+ dev-ml/result:=
+ dev-ml/yojson:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"
+
+PATCHES=( "${FILESDIR}"/${PN}-${PV}-src_test_dune-ounit2.patch )