summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_cold/ppx_cold-0.14.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_cold/ppx_cold-0.14.0-r1.ebuild')
-rw-r--r--dev-ml/ppx_cold/ppx_cold-0.14.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/ppx_cold/ppx_cold-0.14.0-r1.ebuild b/dev-ml/ppx_cold/ppx_cold-0.14.0-r1.ebuild
new file mode 100644
index 000000000000..e7d79d032ea3
--- /dev/null
+++ b/dev-ml/ppx_cold/ppx_cold-0.14.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Expands [@cold] into [@inline never][@specialise never][@local never]"
+HOMEPAGE="https://github.com/janestreet/ppx_cold"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ <dev-ml/base-0.15:=
+ dev-ml/findlib:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+"
+RDEPEND="${DEPEND}"