summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_base/ppx_base-0.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_base/ppx_base-0.9.0.ebuild')
-rw-r--r--dev-ml/ppx_base/ppx_base-0.9.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ppx_base/ppx_base-0.9.0.ebuild b/dev-ml/ppx_base/ppx_base-0.9.0.ebuild
new file mode 100644
index 000000000000..aac278c71193
--- /dev/null
+++ b/dev-ml/ppx_base/ppx_base-0.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Base set of ppx rewriters"
+HOMEPAGE="https://github.com/janestreet/ppx_base"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc"
+IUSE=""
+
+DEPEND="
+ dev-ml/ppx_compare:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_enumerate:=
+ dev-ml/ppx_hash:=
+ dev-ml/ppx_js_style:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/ocaml-migrate-parsetree:=
+ "
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/jbuilder"