summaryrefslogtreecommitdiff
path: root/dev-ml/ounit2/ounit2-2.2.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ounit2/ounit2-2.2.4.ebuild')
-rw-r--r--dev-ml/ounit2/ounit2-2.2.4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/ounit2/ounit2-2.2.4.ebuild b/dev-ml/ounit2/ounit2-2.2.4.ebuild
new file mode 100644
index 000000000000..b67e4a2fd511
--- /dev/null
+++ b/dev-ml/ounit2/ounit2-2.2.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Unit testing framework for OCaml"
+HOMEPAGE="https://github.com/gildor478/ounit"
+SRC_URI="https://github.com/gildor478/ounit/releases/download/v${PV}/ounit-v${PV}.tbz"
+S="${WORKDIR}/ounit-v${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/lwt:=
+ dev-ml/stdlib-shims:=
+"
+RDEPEND="${DEPEND}"