summaryrefslogtreecommitdiff
path: root/dev-ml/opam
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/opam')
-rw-r--r--dev-ml/opam/Manifest2
-rw-r--r--dev-ml/opam/opam-2.2.1.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-ml/opam/Manifest b/dev-ml/opam/Manifest
index 00d6a58a9828..8f72acdb48fd 100644
--- a/dev-ml/opam/Manifest
+++ b/dev-ml/opam/Manifest
@@ -1,3 +1,5 @@
DIST opam-2.1.6.tar.gz 837526 BLAKE2B 1ee60691f4fcc1011f461505942f00ff5f5cc0f0bbfc97edb8e4c676d1e4cd28fed8b49ef341af51a750848be3110713cc97e93a9e63999e4b92e7c7f68d743e SHA512 f75d81b4eb19ef6603e7a2a18e1a281ea6f5eea47b820ae888593102db5b98ded5b593b176e70235611b63a07f4a406a57fe016386f4e921f51b55eb62b9864d
+DIST opam-2.2.1.tar.gz 1089671 BLAKE2B cd6a97c8c19d7866205b49f95bf4215d986b3ad8b5d1fe5c5fd52db9b8b9e0cff8559d478e18d99d89816bbf830910f182e4c1e80719ac29a3cd5c8299450a21 SHA512 17d7d83b9de118332c121b9d3aa2e48f62a6270ea23e730a536b0f4ff060df85238c7c4ab53a89bcc3b3193d52d14358831bd9bed30a4ac699e44e4c3003b8b0
EBUILD opam-2.1.6.ebuild 1247 BLAKE2B b357646bc33c2203de2c7e5d37ae270a510e28837ec5b470da9ff6d2446a56f4a3cb43bf9f2d52df2c31cf7c87898e3f6dd75b4c6b1c9e4369d55c3376cc9f53 SHA512 1bdb058cb0747fa320b1d258125e5d4f2fee53f4e1512ec36ad97df3bd3507268b12520f65ba66b2069ec92527bd0c28da6e8741da19b12a1d53cf4ccc6d051e
+EBUILD opam-2.2.1.ebuild 1356 BLAKE2B 903e59a090461da0ab378927d0e459c89ab892eda34a41deed9872334e27e05a610956084b9c4d6a37ce99c906e3cf91f067803db18b4d712d8785c05a271f76 SHA512 518c179cfe1f7f661779ec920b545109e088ddfe0950283027b7acf4358b739f7fb5d29b331256c68ed69cd8291bbab37c21cbcdcb9cd8aa31d827c51f5e9ad9
MISC metadata.xml 308 BLAKE2B 8063e47b40e4366ef330084a189eafbb580be1231caf276960a3c3a67a34f4cb60be369e2ae75b91b379feda07fc8d7b6d9ccc5fa14c296c9dc2e8bb92d10157 SHA512 0b05ce3d4265c65f2ba372a24a59bbb46b8daa80883501a61da35aa0a8a487cd5fe0cf24cd6c089139893eb1fa970c33ef207e51772583bb137ebd38ec58eca5
diff --git a/dev-ml/opam/opam-2.2.1.ebuild b/dev-ml/opam/opam-2.2.1.ebuild
new file mode 100644
index 000000000000..41dc7badc426
--- /dev/null
+++ b/dev-ml/opam/opam-2.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME="opam"
+inherit dune
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" #see bugs 838658
+
+RDEPEND="
+ dev-ml/0install:=[ocamlopt?]
+ dev-ml/cmdliner:=[ocamlopt?]
+ dev-ml/cudf:=[ocamlopt?]
+ dev-ml/dose3:=[ocamlopt?]
+ dev-ml/extlib:=[ocamlopt?]
+ dev-ml/jsonm:=[ocamlopt?]
+ dev-ml/ocaml-base64:=[ocamlopt?]
+ dev-ml/ocamlgraph:=[ocamlopt?]
+ dev-ml/ocaml-sha:=[ocamlopt?]
+ dev-ml/opam-0install-cudf:=[ocamlopt?]
+ dev-ml/opam-common:=[ocamlopt?]
+ dev-ml/opam-file-format:=[ocamlopt?]
+ dev-ml/re:=[ocamlopt?]
+ dev-ml/spdx_licenses:=[ocamlopt?]
+ dev-ml/stdlib-shims:=[ocamlopt?]
+ dev-ml/swhid_core:=[ocamlopt?]
+ dev-ml/uchar:=[ocamlopt?]
+ dev-ml/uutf:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/findlib"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune-compile opam-solver opam-repository opam-state opam-client ${DUNE_PKG_NAME}
+}
+
+src_install() {
+ dune_src_install
+ mv "${ED}"/usr/share/doc/${PF}/${PN}/* \
+ "${ED}"/usr/share/doc/${PF} || die
+}