summaryrefslogtreecommitdiff
path: root/dev-ml/opam-state/opam-state-2.0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/opam-state/opam-state-2.0.9.ebuild')
-rw-r--r--dev-ml/opam-state/opam-state-2.0.9.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/opam-state/opam-state-2.0.9.ebuild b/dev-ml/opam-state/opam-state-2.0.9.ebuild
new file mode 100644
index 000000000000..cf9ab72c819e
--- /dev/null
+++ b/dev-ml/opam-state/opam-state-2.0.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="opam state libraries"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+RDEPEND="
+ dev-ml/re:=
+ dev-ml/opam-file-format:=
+ ~dev-ml/opam-repository-${PV}:=
+"
+DEPEND="${RDEPEND}"
+
+# Cherry-picked from https://deb.debian.org/debian/pool/main/o/opam/opam_2.0.8-1.debian.tar.xz
+PATCHES=( "${FILESDIR}/debian-Port-to-Dose3-6.0.1.patch" )
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}