summaryrefslogtreecommitdiff
path: root/dev-ml/opam-installer/opam-installer-2.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/opam-installer/opam-installer-2.1.0-r1.ebuild')
-rw-r--r--dev-ml/opam-installer/opam-installer-2.1.0-r1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-ml/opam-installer/opam-installer-2.1.0-r1.ebuild b/dev-ml/opam-installer/opam-installer-2.1.0-r1.ebuild
deleted file mode 100644
index f8f6bf709969..000000000000
--- a/dev-ml/opam-installer/opam-installer-2.1.0-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# We are opam
-OPAM_INSTALLER_DEP=" "
-OPAM_SKIP_VALIDATION=yes
-inherit dune
-
-DESCRIPTION="Core installer for opam packages"
-HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
-SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/dev-ml/opam/opam-2.1.0-dose3-6.patch.xz"
-S="${WORKDIR}/opam-full-${PV/_/-}"
-OPAM_INSTALLER="${S}/_build/install/default/bin/opam-installer"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="+ocamlopt"
-
-PATCHES=( "${WORKDIR}"/opam-2.1.0-dose3-6.patch )
-
-RDEPEND="
- >=dev-lang/ocaml-4.02.3:=
- dev-ml/cmdliner:=
- ~dev-ml/opam-format-${PV}:=
- >=dev-ml/dose3-6:=
-"
-DEPEND="${RDEPEND}
- dev-ml/findlib"
-
-src_configure() {
- econf \
- --prefix="${EPREFIX}/usr" \
- --with-mccs \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --mandir="${EPREFIX}/usr/share/man"
-}