summaryrefslogtreecommitdiff
path: root/dev-ml/odns
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/odns')
-rw-r--r--dev-ml/odns/Manifest4
-rw-r--r--dev-ml/odns/files/odns-0.3-parmake.patch16
-rw-r--r--dev-ml/odns/metadata.xml8
-rw-r--r--dev-ml/odns/odns-0.3-r1.ebuild40
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-ml/odns/Manifest b/dev-ml/odns/Manifest
new file mode 100644
index 000000000000..a03de590b893
--- /dev/null
+++ b/dev-ml/odns/Manifest
@@ -0,0 +1,4 @@
+AUX odns-0.3-parmake.patch 631 BLAKE2B 957d9cab6d1506d1dbda767a62db94edd84421c578ffab5c7c43c4759a9832ae9ac0ba0af1af0a36cb0ed8ec8d535c99337d2ef4ab164cc353c1b1a2b30a4ef4 SHA512 e831d5fc0a310680ed75205b5d08fde65f679fa54791798eca528ccfa245b68f7b2afb320ee70716430fae0cd6d36340d480506cd8cf70b7c53bf067e63cb0b8
+DIST odns-0.3.tar.gz 57616 BLAKE2B de6ac0fee68d1ae21fe279971da252647d30f5914ec2030cb0ecb5efb245ade254673b54b884d1987e673b0117bc58a10b0b6344689134924334dedb919eb888 SHA512 6d40d7fc882185500aaa58582112abd57faf72ee0a57fabc211ad4bf39739b39cb956e6cb109808e05d767560a942c3300e9ec0e6b28c13cec2a2b4dd0c3bf5d
+EBUILD odns-0.3-r1.ebuild 811 BLAKE2B e91d8fa2d25e88d81c6aab720435c656a2d9b0979b6aaa6add8fbe02cfc1bb556190531a13764e972c17516e97b8bb2157cb686f2a895ad26400523935b3d6d9 SHA512 74ad911a4259badce852b24a5d0f806442e2cd3be1795db4bcaafaa8133e9c07f59a2c7ac81c2a124a738bdab9977566226d45e6f80590d972a28db1e670ad48
+MISC metadata.xml 243 BLAKE2B 010ca240ae06e9a9f6d7ba213eb06df36d9ba862ff2d2458d98a9fea1a1e7f3026d13832a73bce1b3ad9345029425e6abfae9e03bf126f2329b3f030ed3753fd SHA512 1c5b4b2163017e496999d1f87e5c9c5ac6c11b2e9187450ccfb3df258f34e54d278972f04ee0e8429476c6f87e091a869ac2a28c6e8c8e6d20678c3e74061449
diff --git a/dev-ml/odns/files/odns-0.3-parmake.patch b/dev-ml/odns/files/odns-0.3-parmake.patch
new file mode 100644
index 000000000000..7034abd25cf2
--- /dev/null
+++ b/dev-ml/odns/files/odns-0.3-parmake.patch
@@ -0,0 +1,16 @@
+fix parallel make
+https://bugs.gentoo.org/show_bug.cgi?id=422683
+
+Index: odns-0.3/OCamlMakefile
+===================================================================
+--- odns-0.3.orig/OCamlMakefile
++++ odns-0.3/OCamlMakefile
+@@ -1152,7 +1152,7 @@ $(BCDIDIR)/%.di $(NCDIDIR)/%.di: %.mli
+ $(DOC_DIR)/$(RESULT)/html:
+ mkdir -p $@
+
+-$(DOC_DIR)/$(RESULT)/html/index.html: $(DOC_DIR)/$(RESULT)/html $(DOC_FILES)
++$(DOC_DIR)/$(RESULT)/html/index.html: $(DOC_DIR)/$(RESULT)/html $(DOC_FILES) byte-code-library
+ rm -rf $</*
+ $(QUIET)pp=`sed -n -e '/^#/d' -e 's/(\*pp \([^*]*\) \*)/\1/p;q' $(FIRST_DOC_FILE)`; \
+ if [ -z "$$pp" ]; then \
diff --git a/dev-ml/odns/metadata.xml b/dev-ml/odns/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/odns/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/odns/odns-0.3-r1.ebuild b/dev-ml/odns/odns-0.3-r1.ebuild
new file mode 100644
index 000000000000..d330c21321f0
--- /dev/null
+++ b/dev-ml/odns/odns-0.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="OCaml library to query DNS servers"
+HOMEPAGE="http://odns.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+# It is ancient and upstream is dead. Consider using ocaml-dns instead.
+RDEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt]
+ !dev-ml/dns
+ !dev-ml/ocaml-dns
+"
+DEPEND="${RDEPEND}"
+
+CLIBS="" # Workaround for bug #422683
+
+src_prepare() {
+ sed -i -e "s/version=\"0.2\"/version=\"${PV}\"/" META || die
+ epatch "${FILESDIR}/${P}-parmake.patch"
+}
+
+src_compile() {
+ emake -j1 #453434
+}
+
+src_install() {
+ findlib_src_preinst
+ PREFIX="${D}/usr" emake install
+ dodoc AUTHORS README
+}