summaryrefslogtreecommitdiff
path: root/dev-ml/ocplib-endian/ocplib-endian-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocplib-endian/ocplib-endian-1.2.ebuild')
-rw-r--r--dev-ml/ocplib-endian/ocplib-endian-1.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ml/ocplib-endian/ocplib-endian-1.2.ebuild b/dev-ml/ocplib-endian/ocplib-endian-1.2.ebuild
new file mode 100644
index 000000000000..43cb3ed3821d
--- /dev/null
+++ b/dev-ml/ocplib-endian/ocplib-endian-1.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Functions to read and write int16/32/64 from strings, bytes, and bigarrays"
+HOMEPAGE="https://github.com/OCamlPro/ocplib-endian"
+SRC_URI="https://github.com/OCamlPro/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+# 2 of 70 tests fail
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/cppo-1.6.6"