summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlweb/ocamlweb-1.41.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlweb/ocamlweb-1.41.ebuild')
-rw-r--r--dev-ml/ocamlweb/ocamlweb-1.41.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-ml/ocamlweb/ocamlweb-1.41.ebuild b/dev-ml/ocamlweb/ocamlweb-1.41.ebuild
index 74561b53a6b0..9f050ccea33b 100644
--- a/dev-ml/ocamlweb/ocamlweb-1.41.ebuild
+++ b/dev-ml/ocamlweb/ocamlweb-1.41.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,19 +12,24 @@ SRC_URI="https://www.lri.fr/~filliatr/ftp/ocamlweb/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
DEPEND=">=dev-lang/ocaml-4.08.0:=
virtual/latex-base
- dev-texlive/texlive-latexextra
- "
+ dev-texlive/texlive-latexextra"
+BDEPEND="test? ( dev-tex/hevea )"
PATCHES=(
"${FILESDIR}/${PN}-1.41-strip.patch"
"${FILESDIR}/${PN}-1.41-ocaml-4.08.0.patch"
)
+QA_FLAGS_IGNORED=/usr/bin/ocamlweb
+
src_compile() {
- emake
+ default
}
src_install() {