summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlfuse
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlfuse')
-rw-r--r--dev-ml/ocamlfuse/Manifest2
-rw-r--r--dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-Wint.patch67
-rw-r--r--dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-unistd.patch10
3 files changed, 0 insertions, 79 deletions
diff --git a/dev-ml/ocamlfuse/Manifest b/dev-ml/ocamlfuse/Manifest
index bfa8eb829fc8..fd8c4aa4a1ca 100644
--- a/dev-ml/ocamlfuse/Manifest
+++ b/dev-ml/ocamlfuse/Manifest
@@ -1,5 +1,3 @@
-AUX ocamlfuse-2.7.1_p7-Wint.patch 1705 BLAKE2B 3e4d208a54d054803f60e9ce1ae6a8b3ca58a3807bc06744d2ed5ccda2d6bafd44f3bd071ae604dce2822d3c31de4d1f710e964dfb95c483a3879c2858ef0cdc SHA512 637b88e6241740de3b04663d3bfb53963a9b1b83cd5efca6827ae575534e83a4e0bfad96a433e6cffffad405352a437c17ca857e39cff6aa650889134c26226b
-AUX ocamlfuse-2.7.1_p7-unistd.patch 259 BLAKE2B 188881834218ea5514bde2bf64f952e759997eeaa11fe0c7e6d12975e29d2274b7453ea4db23ecfe0548afdedbb10b25287b871b9d3d0898576973ecc956ffe8 SHA512 852e6d8352953294b0d5d2f6a3d10b7af4cd1f6514284221470a0ec92b51643f8afaa85ee117c1c21b12ecb8660547a2a58ef12c3cf9b57cdb6620434695acae
DIST ocamlfuse-2.7.1_p11.tar.gz 24403 BLAKE2B 5ea9c3680b857f438439a4ac67992d2524edf60ff98e6bb2783fcb72f63978daa8eb840ba5ff9ab687c30f72991f9f3a96b12800014e4e8408000b1ee5927e78 SHA512 e77bc2bcb77d2f17183c1de6113bd7e4d888f60c6ceacc326e4b03ccfef6f1608b1feef58ed7f6e16fe22d645714c40140580bb19ae52dab11ce62e94dfdd1fa
EBUILD ocamlfuse-2.7.1_p11.ebuild 688 BLAKE2B dc6f20b47257dd0ca777d83958a8285f91c9425452375d36380d29262d1c2fde0f2ba9b786bc2ef9badaa50fe58260eb5f47515991123b3ba105f2329e708502 SHA512 4d28b984a4dba60736453d13f4feb2295f990aba351d6eb02dd1044a296e86fdf51593cc86820251796393058c4766e2c8c0175bfd35bd2ad40838dfc4fb57bc
MISC metadata.xml 990 BLAKE2B 926400ebc857a10b0e2694a7747a1c4d00668e6b123ca867bf0e16d59e69ce060dea1c41f7eb11126676dadbd34268c97c840ffea373230a0bdc5198cd510345 SHA512 d0309f117de7a59f80ee141a4bc55204d4798c69a7f73e4d967168383c236385e280cb9fde03c96570458de029e45ae1a8c24d79e19f4749d8fd15705cd96305
diff --git a/dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-Wint.patch b/dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-Wint.patch
deleted file mode 100644
index 8f1e7f405bf6..000000000000
--- a/dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-Wint.patch
+++ /dev/null
@@ -1,67 +0,0 @@
---- a/lib/Fuse_util.c 2024-05-31 19:58:34.910818884 +0200
-+++ b/lib/Fuse_util.c 2024-05-31 20:25:27.021700407 +0200
-@@ -293,7 +293,6 @@
- }
-
- #define FOR_ALL_OPS(MACRO) \
-- MACRO(init) \
- MACRO(getattr) \
- MACRO(readlink) \
- MACRO(readdir) \
-@@ -344,12 +343,14 @@
- #define SET_NULL_OP(OPNAME) .OPNAME = NULL,
-
- static struct fuse_operations ops = {
-+ SET_NULL_OP(init)
- FOR_ALL_OPS(SET_NULL_OP)
- };
-
- static value * ocaml_list_length=NULL;
-
- #define DECLARE_OP_CLOSURE(OPNAME) static value * OPNAME##_closure=NULL;
-+DECLARE_OP_CLOSURE(init)
- FOR_ALL_OPS(DECLARE_OP_CLOSURE)
-
- #define init_ARGS (struct fuse_conn_info *conn)
-@@ -593,6 +594,33 @@
- #define removexattr_CB vpath = copy_string(path); vres=callback2(*removexattr_closure,vpath,copy_string(name));
- #define removexattr_RES
-
-+static void *gm281_ops_init(struct fuse_conn_info *conn)
-+{
-+ CAMLparam0();
-+ CAMLlocal4(vstring, vpath, vres, vtmp);
-+ intptr_t res = -1;
-+ vres=callback(*init_closure,Val_unit);
-+ if (Tag_val(vres)==1) /* Result is not Bad */
-+ {
-+ res=0;
-+ }
-+ else
-+ {
-+ if (Is_block(Field(vres,0))) /* This is EUNKNOWNERR of int in ocaml */
-+ res=-Int_val(Field(Field(vres,0),0));
-+ else res=-ml2c_unix_error(Int_val(Field(vres,0)));
-+ }
-+ CAMLreturnT(void *, (void *)res);
-+}
-+
-+static void *ops_init(struct fuse_conn_info *conn)
-+{
-+ leave_blocking_section();
-+ void *ret = gm281_ops_init(conn);
-+ enter_blocking_section();
-+ return ret;
-+}
-+
- #define CALLBACK(OPNAME) \
- static OPNAME##_RTYPE gm281_ops_##OPNAME OPNAME##_ARGS \
- {\
-@@ -634,6 +662,7 @@
-
- void set_fuse_operations(struct fuse_operation_names const *op)
- {
-+ SET_OPERATION(init)
- FOR_ALL_OPS(SET_OPERATION)
- }
-
diff --git a/dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-unistd.patch b/dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-unistd.patch
deleted file mode 100644
index b13f906a5ef3..000000000000
--- a/dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-unistd.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/lib/Unix_util_stubs.c 2022-09-20 19:53:44.445778566 +0200
-+++ b/lib/Unix_util_stubs.c 2022-09-20 19:54:03.521504343 +0200
-@@ -24,6 +24,7 @@
- vincenzo_ml@yahoo.it
- */
-
-+#include <unistd.h>
- #include <stddef.h>
- #include <string.h>
- #include <errno.h>