summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlbuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlbuild')
-rw-r--r--dev-ml/ocamlbuild/Manifest3
-rw-r--r--dev-ml/ocamlbuild/files/ocamlbuild-0.15.0-test.patch37
-rw-r--r--dev-ml/ocamlbuild/ocamlbuild-0.15.0.ebuild9
3 files changed, 47 insertions, 2 deletions
diff --git a/dev-ml/ocamlbuild/Manifest b/dev-ml/ocamlbuild/Manifest
index c82515233120..4f38c17fb293 100644
--- a/dev-ml/ocamlbuild/Manifest
+++ b/dev-ml/ocamlbuild/Manifest
@@ -1,3 +1,4 @@
+AUX ocamlbuild-0.15.0-test.patch 1283 BLAKE2B ff89812cdb200b8a4b3b7482f7ca498670e93408d1698a2cc5f417df5e3178d285e7e63f799a94f1514e9c7635c28a60b7fb0094acf683ac092ce4ac6b9018e0 SHA512 b27bb2e3ef0f9303b2dc21815331489c03977a3d254cffc55cb4fed962281b8debe0e10e64c46ba2fc5661590394a99455f8ec68759430da3e878c6f89691078
DIST ocamlbuild-0.15.0.tar.gz 201971 BLAKE2B 34c35c48d446d9c5297a9eabf6d4f134fbfdf01aad4eff15804ad7ecd9068527a70c2d9820ce3f7dba41aa88dda215e82074ad0c66df048c512afd60884ec7fd SHA512 c8311a9a78491bf759eb27153d6ba4692d27cd935759a145f96a8ba8f3c2e97cef54e7d654ed1c2c07c74f60482a4fef5224e26d0f04450e69cdcb9418c762d3
-EBUILD ocamlbuild-0.15.0.ebuild 1320 BLAKE2B 911a653884e1891d3b2a57fdce86563219f0c924a1e02758ef4184dca4ef3c7fabdc08a19e992a818b94a94c4e484eb5ad43ec62946d615b372836a210f70028 SHA512 fc289aeac6dc4bc9675403fe597bcac4aebe613161197381ad462fa57f4025d0e4184c1baadcc7da78cdcf4f9f32e35bbd3769eb97a1bd05a41f6d8f4b7e9fd8
+EBUILD ocamlbuild-0.15.0.ebuild 1396 BLAKE2B 11b9400898595a10d66fc378cf94ebe1937cfcee3dcf99c438915b7478a1ddabb41d925d00965ee1856a8662aec07258abf0c66f92ae8aa6651d5457b34b4049 SHA512 8b4b727370d02708580206e3da8c15d8ca54cdb4de21a3e6e0baa23005591142465c57d8efbf80d4474ad590829eff94a933fcc78e8886f0c7077375a73f1ef9
MISC metadata.xml 314 BLAKE2B 6b6d5017c9d5ad7070b020fbfc85a313a8d89ff664b666504e0a9acc71e934bf5c28487c127846733dadb91fb657c71c70749955f4b713c41813c38336c0a7cf SHA512 6c4a92b198d2a2e52df3c6c223237e513b3eb681d06b2b6a15494c2ca9bf2ec6bfd0fb39cae1ed4e47088f87277fa35f1b959aa797cae4c59ccb764ac75de9e7
diff --git a/dev-ml/ocamlbuild/files/ocamlbuild-0.15.0-test.patch b/dev-ml/ocamlbuild/files/ocamlbuild-0.15.0-test.patch
new file mode 100644
index 000000000000..db02dd5de732
--- /dev/null
+++ b/dev-ml/ocamlbuild/files/ocamlbuild-0.15.0-test.patch
@@ -0,0 +1,37 @@
+From c70704cc301cfd826cc3950f26af674b3b3bfab4 Mon Sep 17 00:00:00 2001
+From: Hugo Heuzard <hugo.heuzard@gmail.com>
+Date: Mon, 10 Mar 2025 10:53:27 +0100
+Subject: [PATCH] Testsuite: fix for OCaml 5.3
+
+---
+ testsuite/internal.ml | 10 +++++++++-
+ 1 file changed, 9 insertions(+), 1 deletion(-)
+
+diff --git a/testsuite/internal.ml b/testsuite/internal.ml
+index 0b9ac319..eb221cb1 100644
+--- a/testsuite/internal.ml
++++ b/testsuite/internal.ml
+@@ -314,7 +314,7 @@ Error: This expression has type int but an expression was expected of type
+ unit
+ because it is in the left-hand side of a sequence
+ Command exited with code 2.|}
+-else
++else if Sys.ocaml_version < "5.3.0" then
+ {|File "hello.ml", line 1, characters 9-10:
+ 1 | let () = 1; ()
+ ^
+@@ -322,6 +322,14 @@ Error: This expression has type "int" but an expression was expected of type
+ "unit"
+ because it is in the left-hand side of a sequence
+ Command exited with code 2.|}
++else
++{|File "hello.ml", line 1, characters 9-10:
++1 | let () = 1; ()
++ ^
++Error: The constant "1" has type "int" but an expression was expected of type
++ "unit"
++ because it is in the left-hand side of a sequence
++Command exited with code 2.|}
+ )
+ ~targets:("hello.byte",[]) ();;
+
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.15.0.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.15.0.ebuild
index 1fbdfe7dc118..a56cc131cd0e 100644
--- a/dev-ml/ocamlbuild/ocamlbuild-0.15.0.ebuild
+++ b/dev-ml/ocamlbuild/ocamlbuild-0.15.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,6 +17,9 @@ DEPEND="${RDEPEND}
dev-ml/findlib"
QA_FLAGS_IGNORED='.*'
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
src_prepare() {
sed -i \
-e "/package_exists/s:camlp4.macro:xxxxxx:" \
@@ -48,3 +51,7 @@ src_install() {
emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
dodoc Changes
}
+
+src_test() {
+ emake -j1 test
+}