summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlbuild/ocamlbuild-0.14.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlbuild/ocamlbuild-0.14.0-r1.ebuild')
-rw-r--r--dev-ml/ocamlbuild/ocamlbuild-0.14.0-r1.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.14.0-r1.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.14.0-r1.ebuild
index bf4f3bb4acf3..47ec79c0341e 100644
--- a/dev-ml/ocamlbuild/ocamlbuild-0.14.0-r1.ebuild
+++ b/dev-ml/ocamlbuild/ocamlbuild-0.14.0-r1.ebuild
@@ -9,7 +9,7 @@ SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz
LICENSE="LGPL-2.1-with-linking-exception"
SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="+ocamlopt test"
RESTRICT="!test? ( test )"
@@ -25,6 +25,13 @@ PATCHES=(
)
QA_FLAGS_IGNORED='.*'
+src_prepare() {
+ sed -i \
+ -e "/package_exists/s:camlp4.macro:xxxxxx:" \
+ -e "/package_exists/s:menhirLib:xxxxxx:" \
+ testsuite/external.ml || die
+ default
+}
src_configure() {
emake -f configure.make Makefile.config \
@@ -36,6 +43,11 @@ src_configure() {
NATDYNLINK=$(usex ocamlopt true false)
}
+src_compile() {
+ emake src/ocamlbuild_config.cmo
+ default
+}
+
src_install() {
emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
dodoc Changes