summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-ctypes
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-ctypes')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest4
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1-r1.ebuild (renamed from dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1.ebuild)2
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.19.1.ebuild43
3 files changed, 47 insertions, 2 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 2e5ed9c2218d..d4ec1320bb51 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -1,3 +1,5 @@
DIST ocaml-ctypes-0.17.1.tar.gz 208101 BLAKE2B b9fe6632058a670c988ba9f1ae81b75aa5373de7231cef04d5e2ede61a44cbaa0324c04197a0a202847599a9bbe7dccd18fd3279f3f351493aaec4959caf3ada SHA512 1e197009f7e6b29b43944f757e987934337ebfa11bb2ff2ca8ba3ebc607e37cf1259d07a90d7faf4b91b49ee20d5c65357ad305f34ada0a8d336a3904233150e
-EBUILD ocaml-ctypes-0.17.1.ebuild 802 BLAKE2B 2d66c3d0f963c246c8640da69b5c4607ca7f312912a2c1873fb62199ec833d10b4c6188dec099efe498f6890a06ea5a3d67499d6bb97eb82a1e3d6c68b588f04 SHA512 bf8959d8cf7319fbd61cb2b29a33b98df5539ffce0352ddd71304e6709b965635181eae53cc3c3b57f2e18590b7843a67c5c9d8be62c757df21ea0de3721af7a
+DIST ocaml-ctypes-0.19.1.tar.gz 206762 BLAKE2B 29b4636e711b9b3ecf3de5d66b796d4d8ddf1109fd7b065666577ce9412e0ef3712f704729dac3b9467ac7ace8f501b90bfc1dc82b86dbe1668e5d13be46741f SHA512 cbf422a2c457b215815a04122d0522ed0f274c5927cecd25951472de6cc6fcd1151b67f95d6bbfeeb3b5f15a9fe9bdedb8861e77bd0de9902418962065e4dfc0
+EBUILD ocaml-ctypes-0.17.1-r1.ebuild 800 BLAKE2B 4df19810dd960c6d51525dde9dc2b374e7ffed06102bdb6622c847b621e699caba711e3b1ca06ea4daeeb87fb7ec05c0c3a41c8b58120ce658633ffeacd8fd09 SHA512 2239d8cef4ce0c401be0422dd8daf73de29322228ad7764c5d0e2d558bdbfc65d77728a97ff2a7987bb502a45ba8774108ec7f18f247d8dd31d22af4068b4786
+EBUILD ocaml-ctypes-0.19.1.ebuild 817 BLAKE2B ce1f9c51e262f069cac6e6d0396c382f28cddb09e28adbb1d873ad7a9d466860ced15d2d1b7590afd25eba79ccd68cb1199faa20d482570ac044699dbaf09f57 SHA512 19f2335492966ac510b38c22902d155d99110e120da4bf6e9a051eaf6eb5c5f668f4799eb40830b845f5b193aa604057b86c152858427209bf216019cd198016
MISC metadata.xml 331 BLAKE2B 7deaed237d1fd18b923d5a0dee3595a7c59f35a0a4e900c417d52fad7d659d6db8b1f36d64a859df6a7770c401b9d8054f51a93dd6fdb738a34a82d8a7b08620 SHA512 35d5acf562fbf2745c71984f7bd26c5ade620c55b23a76a5b443a401a5484a3c58a74e1ab9ae0a0128b2a16c43f661f69e98cb886a3053cfc581ac618ff5c896
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1-r1.ebuild
index d1a9ccf78657..a473cbada2f3 100644
--- a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1.ebuild
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1-r1.ebuild
@@ -17,7 +17,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
>=dev-lang/ocaml-4.02:=[ocamlopt]
- >=dev-libs/libffi-3.3_rc0:0/7
+ >=dev-libs/libffi-3.3_rc0:=
dev-ml/integers:=
"
DEPEND="${RDEPEND}
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.19.1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.19.1.ebuild
new file mode 100644
index 000000000000..40a1bee9e11b
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.19.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ >=dev-libs/libffi-3.3_rc0:=
+ dev-ml/bigarray-compat:=
+ dev-ml/integers:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 dev-ml/lwt )"
+
+src_prepare() {
+ sed -e 's/oUnit/ounit2/g' -i Makefile.tests || die
+ default
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}