summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild')
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild b/dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild
new file mode 100644
index 000000000000..33e8871a4f73
--- /dev/null
+++ b/dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A modular standard library focused on data structures"
+HOMEPAGE="https://github.com/c-cube/ocaml-containers"
+SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/result:=
+ >=dev-ml/sequence-0.9:=
+"
+DEPEND="${RDEPEND} dev-ml/cppo
+ test? ( dev-ml/iTeML dev-ml/ounit dev-ml/gen )"
+
+src_configure() {
+ oasis_configure_opts="
+ --enable-unix
+ --disable-bench
+ " oasis_src_configure
+}