summaryrefslogtreecommitdiff
path: root/dev-ml/num/num-1.4-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/num/num-1.4-r3.ebuild')
-rw-r--r--dev-ml/num/num-1.4-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/num/num-1.4-r3.ebuild b/dev-ml/num/num-1.4-r3.ebuild
new file mode 100644
index 000000000000..70fe28fb9f8c
--- /dev/null
+++ b/dev-ml/num/num-1.4-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Not using dune for now, bug #775119
+inherit findlib
+
+DESCRIPTION="Library for arbitrary-precision integer and rational arithmetic"
+HOMEPAGE="https://github.com/ocaml/num"
+SRC_URI="https://github.com/ocaml/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+BDEPEND="${RDEPEND}"
+DEPEND="dev-ml/findlib:=[ocamlopt?]"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" NATDYNLINK="$(usex ocamlopt true false)"
+}
+
+src_test() {
+ # Override needed to not use dune
+ emake test
+}
+
+src_install() {
+ findlib_src_install
+
+ if has_version ">=dev-ml/findlib-1.9" ; then
+ # See bug #803275
+ rm "${ED}/usr/$(get_libdir)/ocaml/num-top/META" || die
+ fi
+}