summaryrefslogtreecommitdiff
path: root/dev-ml/num/num-1.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/num/num-1.4-r1.ebuild')
-rw-r--r--dev-ml/num/num-1.4-r1.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-ml/num/num-1.4-r1.ebuild b/dev-ml/num/num-1.4-r1.ebuild
deleted file mode 100644
index cf5b56b7a6d8..000000000000
--- a/dev-ml/num/num-1.4-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Not using dune for now, bug #775119
-inherit findlib
-
-DESCRIPTION="Library for arbitrary-precision integer and rational arithmetic"
-HOMEPAGE="https://github.com/ocaml/num"
-SRC_URI="https://github.com/ocaml/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1-with-linking-exception"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="+ocamlopt"
-
-RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
-
-src_compile() {
- emake CFLAGS="${CFLAGS}" NATDYNLINK="$(usex ocamlopt true false)"
-}
-
-src_test() {
- # Override needed to not use dune
- emake test
-}
-
-src_install() {
- findlib_src_preinst
- OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install DESTDIR="${D}" NATDYNLINK="$(usex ocamlopt true false)"
-}