summaryrefslogtreecommitdiff
path: root/dev-ml/mtime/mtime-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/mtime/mtime-1.1.0.ebuild')
-rw-r--r--dev-ml/mtime/mtime-1.1.0.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-ml/mtime/mtime-1.1.0.ebuild b/dev-ml/mtime/mtime-1.1.0.ebuild
deleted file mode 100644
index 70153205a2bd..000000000000
--- a/dev-ml/mtime/mtime-1.1.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit opam
-
-DESCRIPTION="OCaml module to access monotonic wall-clock time"
-HOMEPAGE="https://erratique.ch/software/mtime https://github.com/dbuenzli/mtime"
-SRC_URI="https://erratique.ch/software/mtime/releases/${P}.tbz"
-
-LICENSE="ISC"
-SLOT="0/${PV}"
-KEYWORDS="amd64 arm arm64 ~ppc ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-lang/ocaml:=[ocamlopt]"
-DEPEND="${RDEPEND}
- dev-ml/topkg
- dev-ml/ocamlbuild
- dev-ml/findlib"
-
-src_compile() {
- ocaml pkg/pkg.ml build \
- --with-js_of_ocaml false \
- --tests $(usex test true false) \
- || die
-}
-
-src_test() {
- ocaml pkg/pkg.ml test || die
-}