summaryrefslogtreecommitdiff
path: root/dev-ml/memtrace/memtrace-0.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/memtrace/memtrace-0.2.3.ebuild')
-rw-r--r--dev-ml/memtrace/memtrace-0.2.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/memtrace/memtrace-0.2.3.ebuild b/dev-ml/memtrace/memtrace-0.2.3.ebuild
new file mode 100644
index 000000000000..d66a6056658c
--- /dev/null
+++ b/dev-ml/memtrace/memtrace-0.2.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION=" Streaming client for OCaml's Memprof "
+HOMEPAGE="https://github.com/janestreet/memtrace/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/janestreet/${PN}.git"
+else
+ SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+ocamlopt"