summaryrefslogtreecommitdiff
path: root/dev-ml/mccs/mccs-1.1.2c.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/mccs/mccs-1.1.2c.ebuild')
-rw-r--r--dev-ml/mccs/mccs-1.1.2c.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/mccs/mccs-1.1.2c.ebuild b/dev-ml/mccs/mccs-1.1.2c.ebuild
new file mode 100644
index 000000000000..3451a9f9423a
--- /dev/null
+++ b/dev-ml/mccs/mccs-1.1.2c.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator opam
+
+MY_PV=$(replace_version_separator 2 '+')
+
+DESCRIPTION="Multi Criteria CUDF Solver"
+HOMEPAGE="http://www.i3s.unice.fr/~cpjm/misc/ https://github.com/AltGr/ocaml-mccs/issues"
+SRC_URI="https://github.com/AltGr/ocaml-mccs/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-ml/cudf:=
+ sci-mathematics/glpk:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder"
+
+S=${WORKDIR}/ocaml-${PN}-$(replace_version_separator 2 '-')
+
+src_compile() {
+ jbuilder build -p ${PN} || die
+}