summaryrefslogtreecommitdiff
path: root/dev-ml/luv/luv-0.5.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/luv/luv-0.5.10.ebuild')
-rw-r--r--dev-ml/luv/luv-0.5.10.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ml/luv/luv-0.5.10.ebuild b/dev-ml/luv/luv-0.5.10.ebuild
new file mode 100644
index 000000000000..a30ace7876a3
--- /dev/null
+++ b/dev-ml/luv/luv-0.5.10.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Binding to libuv: cross-platform asynchronous I/O"
+SRC_URI="https://github.com/aantron/${PN}/releases/download/${PV}/${P}.tar.gz"
+HOMEPAGE="https://github.com/aantron/luv"
+
+SLOT="0/${PV}"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-ml/ocaml-ctypes"
+DEPEND="${RDEPEND}"
+BDEPEND=""