summaryrefslogtreecommitdiff
path: root/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
index f8d000150fbb..5fb5269eb058 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
@@ -28,6 +28,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0/${PV}"
KEYWORDS=""
IUSE="debug test ${ALL_LLVM_TARGETS[*]}"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -35,16 +36,15 @@ RDEPEND="
dev-ml/ocaml-ctypes:=
~sys-devel/llvm-${PV}:=[${LLVM_TARGET_USEDEPS// /,},debug?]
!sys-devel/llvm[ocaml(-)]"
+DEPEND="${RDEPEND}"
# configparser-3.2 breaks the build (3.3 or none at all are fine)
-DEPEND="${RDEPEND}
+BDEPEND="
dev-lang/perl
dev-ml/findlib
test? ( dev-ml/ounit )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
-REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
-
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo