summaryrefslogtreecommitdiff
path: root/dev-ml/lambda-term/lambda-term-3.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/lambda-term/lambda-term-3.3.1.ebuild')
-rw-r--r--dev-ml/lambda-term/lambda-term-3.3.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/lambda-term/lambda-term-3.3.1.ebuild b/dev-ml/lambda-term/lambda-term-3.3.1.ebuild
new file mode 100644
index 000000000000..a24670b816de
--- /dev/null
+++ b/dev-ml/lambda-term/lambda-term-3.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Terminal manipulation library for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/lambda-term"
+SRC_URI="https://github.com/ocaml-community/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/camomile:=
+ >=dev-ml/lwt-5.4:=
+ dev-ml/lwt_log:=
+ dev-ml/mew_vi:=
+ dev-ml/react:=
+ dev-ml/zed:=
+"
+DEPEND="${RDEPEND}"